Changing your Framer Library version

Note: This article refers to the Framer desktop app. Learn more about the differences between the Framer web and desktop app here.

The Framer Library is what allows animations and transitions to work well in Framer. Each time we add new features or support for certain animations, we release a new version.

Why change the Library version?

Sometimes you may want to try out a new beta version that fixes a bug for you, or you may want to go back to a previous version.

For instance, because a package you installed was created supporting an older Library version, or because you work with older projects containing code that may still rely on the older animation library before our Playground release.

If everything looks out of place in your Preview, it may also be an indication that you are accidentally set to an older Library version.

Setting a previous Library version

On the desktop app, you can set the Library version by following these steps:

  1. Within the app, navigate to the File menu
  2. Select Framer Library Version
  3. Choose the version you need

The Built-in version is generally the current recommended version and should be your default one for normal expected behavior.

Any version with a number below 1.0.0 concerns a version of our animation library before mid-2019, while 1.0.0 and up concerns the new animation library released with our Playground release.